Plug and Play Drop On Harness
MS3-Pro LSx Drop On Harness

For engines with 58X crank triggers

Thank you for buying our drop on wiring harness! We have designed this harness to support anything from a stock motor swapped into a vintage muscle car to serious drag cars. If you have any questions about the installation, please contact us at support@diyautotune.com.

Parts included

The package includes the following items:

- MS3-Pro ECU
- USB thumb drive with software and instructions
- Complete wiring harness with fuse block and fuses included
- Two cam sensor harnesses – one for VVT motors and one for non-VVT applications
- RS232 (DB9) serial tuning cable and DB9 to sealed 4 pin adapter
- USB tuning cable
- 6 pin gray connector for O2 sensor connections
- 6 pin black connector for transmission control or other expansion devices
- 15 crimp pins for above connectors
- 100 ohm resistor for alternator light installation
- Ground wire for fuel pump

The MS3-Pro will include a full TunerStudio registration with purchase. To register TunerStudio, you will need to go to this link and enter the serial number, found on a silver sticker on the
underside of the ECU.

https://www.efianalytics.com/ms3pro/

The registration code is valid for one user with up to three tuning computers, and there is no limit to how many ECUs you may use with the registered version of TunerStudio.

**Applications**

This harness is designed to fit all engines in the LS family that used a 58X crank trigger, including Corvette, F-body, and truck engines, as well as common crate motors. We offer three variations, based on the injector type. The harness has been cut so that it can accommodate both car and truck intake manifolds, as well as most aftermarket manifold options that use a forward facing throttle body. You will need to use a cable operated throttle body with OEM style TPS and IAC connectors; non stock sensors or IAC valves may require minor changes. A few unusual intake manifolds (particularly carburetor style or independent runner designs) will need extending some of the wires to fit relocated components.

![Injector with EV1 connector](image1)

![Injector with truck (Multec) connector](image2)

![Injector with EV6 connector](image3)

There are a few engine variations that may require minor changes. For example, a few truck engines used a one wire oil pressure sensor switch, located behind the intake manifold. Using the MS3-Pro's oil pressure input will require swapping to a three wire oil pressure sensor. Some alternator brackets (particularly aftermarket alternator relocation kits) may require extending the alternator connection. We have a plug in extension cable (part number MS3Ph-LSAlt) for the alternator connection if you want to extend this without any splicing or cutting.

This harness is set up for a connector-style starter, as this plug can be difficult to find. For earlier starters, you can splice a ring terminal or cut the solenoid wire and loop it around the solenoid pin.

**Pre-installation considerations**

This harness is designed for installing the MS3-Pro and fuse block in the passenger compartment. These parts are capable of withstanding underhood heat if they are mounted at least 12" (30 cm) from the exhaust system. For unusually high vibration installations, use rubber vibration isolators to mount the ECU. The MS3-Pro is splash resistant but not intended to be kept underwater continuously. It can stop water from getting in for about 5 minutes, but after that, water can start seeping into the case. If you need continuous immersion resistance, you can seal the case with RTV silicone.

We used high temperature wire for the harness, but you will want to avoid routing it too close to the exhaust system as well.
**Installing the harness**

The harness is split into two branches on the engine, with the branches joining above the bellhousing. The even numbered cylinder section includes the crank sensor, right injector and coil banks, right knock sensor, MAP sensor, starter solenoid, and IAT (intake air temperature) sensor connectors. The odd numbered section includes connectors for the oil pressure sensor (connected to Analog In 2), left knock sensor, cam position sensor, left injector and coil banks, alternator, coolant temperature sensor, throttle position sensor, and IAC valve.

The branch marked "Body" contains critical connections to the vehicle electrical system. These wires are color coded.

- **Purple**: Starter solenoid power. Connect to starter relay. 14 gauge.
- **Brown**: Alternator light. The alternators on these motors use the same wire to supply a turn on signal and activate a warning light at low output. 20 gauge.
- **White / Red**: 12 volt switched power. 20 gauge.
- **Purple / Red**: Supplies 12 volts for the fuel pump. 10 gauge.
- **Light green / Purple**: Tach output signal. This supplies a tach signal to stock or aftermarket tachometers, and can also supply an RPM signal to other devices such as shift lights, fuel pump controllers, or anything else that can accept a tach signal. Output is a 0-12 volt square wave. Some factory tachometers may need a high voltage tach adapter. 20 gauge.

Before installing the harness, check to be sure you have access to the rear of the engine. On some swaps, you may have an easier time installing the harness if you first unbolt the hood to improve accessibility.

**Step-by-step Wiring Directions:**

1. Disconnect the battery.
2. Begin by cutting a hole in the firewall and feeding the harness through from the inside to the engine. Minimum recommended hole diameter for the wiring harness is 1.75\" (45 mm).

3. Under the hood, start with the odd numbered cylinder branch of the harness, and position it along or under the injector fuel rail. Connect the IAC, TPS, coolant temperature, odd numbered injectors, left coil subharness, and alternator connections. If the alternator does not mount in the stock F-body or truck location high on the left side, you can splice and extend the alternator connection wire, or use our MS3Ph-LSAlt plug in extension.
4. No alternator charging wire is included with the harness due to the large number of possible battery locations. Connect the alternator output terminal lug to the battery positive terminal. Use a minimum of 4 gauge for a 150 amp alternator, 6 gauge for 100 gauge wire. For additional protection, we recommend installing a circuit breaker on this wire.

5. Two connectors on the left side connect underneath the engine. The left knock sensor is located on the side of the block. The cam sensor uses a small pigtail with a connector on the bottom of the timing cover. We have provided two adapters to connect the cam sensor, one for VVT motors (which use a 5 pin connector) and one for motors without VVT (which use a 3 pin connector).
6. At the back of the engine, the harness has a connector for the oil pressure sensor. It also includes a ring terminal to ground the coils that connects to the bolt hole on the back of the cylinder head using an M10 x 1.5 mm bolt. Make sure the bolt is torqued down tightly and the ring terminal is not able to rotate when the bolt is tightened. Using a too-long bolt can result in a bad connection and intermittent sparks.

7. The harness also incorporates a single heavy gauge green wire that starts at its split point. This wire supplies 12 volt fused power which can be used to run a cooling fan or other ECU controlled device through a relay in the fuse box. The MS3-Pro drives this output through High Current Out 1.

8. Run the even numbered cylinder harness under or along the fuel rail. Connect the even numbered injector plugs and the right hand coil subharness plug.

9. The MAP sensor is located at the front of the intake manifold. We have included two separate MAP sensor connectors as there are several style sensors used depending on the year and application. The unused connector may be taped off out of the way.

10. Bolt the ring terminal at the front of the even numbered cylinder harness to the front of the cylinder head using a M10 x 1.5 mm bolt. Make sure the ring terminal is not able to rotate on the bolt.
11. Connect the IAT sensor. If your engine does not have a provision for the IAT, you can either mount it using a bung in the charge pipe, or tap into a suitable location on the intake manifold and thread an IAT sensor into this. Some intake manifolds have fittings that can be drilled and tapped for this purpose. If you are using a metal intake manifold, we recommend mounting the IAT sensor in the charge pipe instead.

12. Remove the starter. Run the foil wrapped wire down to the vicinity of the starter.

13. Connect the crankshaft position (CKP) and starter relay wires. The starter relay terminal included is a connector style; if using an earlier style starter, you can splice on a ring terminal or cut and strip the wire to attach to the starter solenoid stud. This branch also includes the right hand knock sensor wire.

14. Re-install the starter.
15. The branch with 4 gauge wire and the 20 gauge white wire connects to the battery or master disconnect switch. The red wire and the white both connect to the positive terminal, while the black wire connects to the negative terminal. Optionally, you can use a circuit breaker on the 4 gauge red wire. (125 to 150 amp circuit breaker recommended)

16. Next, you will connect the five wires on the Body harness.

17. Connect the solid purple starter wire to the vehicle's starter relay wire. This will trigger the starter solenoid.

18. Connect the brown alternator wire to the alternator warning light wire. We recommend putting a 100 ohm, 2 watt or greater resistor (included with the harness) in parallel with the alternator light to energize the alternator if the light fails. If the vehicle does not have an alternator warning light, connect to switched 12 volts through the supplied resistor.

19. Connect the white and red wire to a wire from the ignition key that receives 12 volt power with the key in both the Run and Start positions.

20. The purple and red wire supplies 12 volts to the fuel pump. Connect this wire to the fuel pump positive terminal. If you do not have a wire for the negative terminal, you can use the supplied fuel pump ground wire to connect the negative terminal to chassis ground.

21. Connect the light green and purple wire to the vehicle's tachometer signal wire, if so equipped.

As this is a racing harness, it does not include all the connectors that come on an OEM wiring harness. You may have several devices on your engine that do not have a connector provided in our harness, including the following items:

- Mass air flow (MAF) sensor
- Clutch switch
- OBD2 diagnostic port
- Evaporative emission canister purge solenoid
- Oil level sensor
- EGR control solenoid

The MS3-Pro is a racing engine controller and does not require these features to run.
The O2 sensor inputs are brought out to a separate 6 pin connector, as we anticipate that most users are more likely to run aftermarket wideband O2 sensor systems instead of factory O2 sensors.

**Connecting optional features**

All unused wires to the MS3-Pro are brought out on the Spare wire trunk.

![Spare wire trunk](image)

You can use these wires for A/C control, boost control, additional sensors, traction control, or other inputs and outputs. Vehicle speed input is optional; the MS3-Pro does not need to use vehicle speed for most of its calculations. See the MS3-Pro manual for details on using these connections. All wires on the spare harness are 20 gauge.

<table>
<thead>
<tr>
<th>Connector</th>
<th>Pin number</th>
<th>Function</th>
<th>Wire color</th>
<th>Stripe color</th>
</tr>
</thead>
<tbody>
<tr>
<td>White</td>
<td>2</td>
<td>High current out 2</td>
<td>Light green</td>
<td>Dark blue</td>
</tr>
<tr>
<td>White</td>
<td>3</td>
<td>Injector out J</td>
<td>White</td>
<td>Yellow</td>
</tr>
<tr>
<td>White</td>
<td>4</td>
<td>Injector out I</td>
<td>White</td>
<td>Gray</td>
</tr>
<tr>
<td>White</td>
<td>5</td>
<td>High current out 3</td>
<td>Light green</td>
<td>Red</td>
</tr>
<tr>
<td>White</td>
<td>18</td>
<td>Sensor ground</td>
<td>Black</td>
<td>White</td>
</tr>
<tr>
<td>White</td>
<td>21</td>
<td>Analog in 3</td>
<td>Light blue</td>
<td>Dark blue</td>
</tr>
<tr>
<td>White</td>
<td>29</td>
<td>PWM out 2</td>
<td>Light green</td>
<td>Pink</td>
</tr>
<tr>
<td>White</td>
<td>30</td>
<td>PWM out 3</td>
<td>Light green</td>
<td>Dark green</td>
</tr>
<tr>
<td>White</td>
<td>32</td>
<td>Digital switched in 1</td>
<td>Gray</td>
<td>Orange</td>
</tr>
<tr>
<td>Gray</td>
<td>17</td>
<td>Digital frequency in 2</td>
<td>Purple</td>
<td>Red</td>
</tr>
<tr>
<td>Gray</td>
<td>19</td>
<td>Digital switched 12V in</td>
<td>Gray</td>
<td>Dark blue</td>
</tr>
<tr>
<td>Gray</td>
<td>20</td>
<td>Digital switched in 2</td>
<td>Gray</td>
<td>Red</td>
</tr>
<tr>
<td>------</td>
<td>-----</td>
<td>----------------------</td>
<td>------</td>
<td>------</td>
</tr>
<tr>
<td>Gray</td>
<td>21</td>
<td>Digital frequency in 3</td>
<td>Purple</td>
<td>Dark blue</td>
</tr>
<tr>
<td>Gray</td>
<td>28</td>
<td>Digital frequency in 1</td>
<td>Purple</td>
<td>White</td>
</tr>
<tr>
<td>Gray</td>
<td>29</td>
<td>Digital switched in 3</td>
<td>Gray</td>
<td>Purple</td>
</tr>
</tbody>
</table>

Sample device wiring

2 step input switch:

![Sample device wiring diagram](image)

Boost control solenoid:

![Boost control solenoid diagram](image)
**Vehicle speed sensor:**

This diagram shows how to use the DIYAutoTune threaded body Hall effect sensor as a driveshaft or wheel speed sensor. This particular sensor requires a 2.4K resistor between its power and signal wires, and the color scheme is a bit unusual – brown is power, black is signal, and blue is ground. Any digital frequency input can be used as a speed input. It is also possible to use a switched input for speed input, although the maximum speed it can measure with these inputs is significantly lower.

If using a MicroSquirt to control the transmission, the MicroSquirt will transmit vehicle speed to the MS3-Pro over the CAN connection. Tip: To get a vehicle speed signal off a front wheel, you can often use one of our Hall effect sensors and have it pick up the back of the wheel studs.

**Oxygen sensors**

As we expect most customers will not be using the stock O2 sensors, we have brought the O2 connection to a gray 6 pin Amphenol AT connector for making connections to factory or aftermarket oxygen sensors. Here is how this connector is pinned out.

1. No connection.
2. Second O2 sensor signal (MS3-Pro Analog Input 1).
3. Primary O2 sensor signal (MS3-Pro O2 Input).
4. Sensor ground. If using a 4 wire O2 sensor, connect the sensor returns here. If using a wideband controller with a separate analog ground, connect it to this wire.
5. Power ground. If your sensor or controller has a heater ground, this is where to connect it. If your wideband controller has only one ground, connect it here.
6. Switched 12 volt power. Use for powering a 4 wire sensor heater or for powering a wideband controller.

The black TCU connector can be used for a MicroSquirt controlling the transmission, a CAN-EGT, aftermarket dash, or other CAN enabled devices. Here is its pinout.
1. Clean power. Use for powering the MicroSquirt, CAN-EGT, or other digital device.
2. CAN bus high.
3. CAN bus low.
4. No connection.
5. Ground.
6. Solenoid power. Use for powering transmission shift solenoids or other actuators.

**Relay module**

The harness is equipped with a sealed module that uses mini (ATM type) fuses and micro relays. Here is a diagram of the relays and fuses. Note that inserting a fuse (any size) into the empty slot marked "Test" will cause the fuel pump, injectors, and coils to power up at any time the key is on, bypassing the MS3-Pro fuel pump output control. This is to help with troubleshooting.

The four holes at the corners of the relay module are threaded for #10-32 machine screws. Use caution while tightening these, as the maximum torque is 24 in-lbs.

The MS3-Pro allows testing the injectors and coils before you attempt to start this engine. If you want to use this feature, we recommend removing the fuel pump relay before running this test to prevent the fuel pump from pressurizing the fuel rails. The MS3-Pro will switch the fuel pump on for two seconds when it first receives power, so do this before you first turn the key on.

**Variable Valve Timing**

The MS3-Pro harness includes provisions for variable valve timing solenoid control. This uses output channel PWM1 to control the solenoid. See the MS3-Pro manual for details on VVT tuning.

**Getting ready to start**

Once you have the harness on the engine, you will need to connect to the ECU with TunerStudio
and select a suitable base map for the engine.

**Installing the software**

The USB stick may automatically install TunerStudio when you plug it into the computer. If it does not start installing the program automatically, select the USB stick manually and run the Setup.exe file. We'll present a short walk-through of how to set it up here; for full details, consult section 2 of the main MS3-Pro manual.

Once the software installs, connect the MS3-Pro to the laptop using either the USB or RS232 cable. Click the Create New Project command in TunerStudio. The screen below will appear.

You can enter a name for the project in (1). Next, click the Detect button (2). TunerStudio will detect what firmware is on your MS3-Pro. If it does not have a definition file, it will prompt you to download one from the Internet, which TunerStudio will handle automatically for any standard release version of the MS3-Pro firmware. You can also enter notes about this project in (3). Click the Next button to move on to the next set of options.
The next screen will let you select project specific settings. The first option will let you display the air/fuel ratio if using a wideband oxygen sensor, or voltage from a narrow band oxygen sensor. The second option sets the temperature display to Fahrenheit or Celsius. You can leave the other options at their defaults. Clicking Next again will give you a screen where you can test communications. Click Next again to bring up a screen where you can select your gauge layout, and then click Next to finish creating the project. Once you've made a project, TunerStudio will bring up its main screen.

**Entering settings for your specific engine**

If ordered as a package with the LS drop on harness, the MS3-Pro will ship with a startup tune based on a stock 6.0 truck motor. You will need to make a number of adjustments to match what engine variant and sensors you are using.

The USB thumb drive includes several alternate startup tunes. Some third party resellers may also provide tunes for specific packages as well. To select an alternate startup tune, go to File -> Open Tune (MSQ). If using a tune from the USB drive, browse to the USB drive. Double click on the tune to open it.

Next, we'll need to make sure the tune is set up for your engine size. Go to Basic / Load Settings and select Engine and Sequential Settings. You will enter the engine size in cc and the injector size in cc/min in the lower right hand corner of the box that opens. (If you only have the injector size in lb/hr, multiplying this by 10.5 will give you the size in cc/min.) Once you have entered these settings, click the "Required Fuel..." button in the upper left hand corner. Make sure all the settings in this box are correct, then click OK. Once this is done, click Burn and close the Engine and Sequential Settings box.

The other main setting that you will need to set to match your build is the oxygen sensor. To set it for this, go to the Tools menu and select Calibrate AFR Table. (If this is grayed out, first unlock it under Tools -> Un / Lock Calibrations.) Select your sensor type from the drop-down menu, then click Write to Controller. We also recommend calibrating the TPS at this point. Go to Tools -> Calibrate TPS. With the throttle closed, "Get Current" on the closed throttle. Then fully open the throttle and "Get Current" on the open throttle. Then click "Accept." If you are running other non-stock sensor types, such as a 3 bar MAP sensor, you will also want to calibrate these from the Tools menu. Once all calibrations are complete, use Tools -> Un / Lock Calibrations to lock these settings so they cannot accidentally be changed.
There's a second place to set the oxygen sensors. Go to Fuel Settings -> AFR / EGO Control to bring up the EGO control menu. You will need to enter your O2 sensor type and the number of O2 sensors in use at the top of the middle column of this screen. If you are using two O2 sensors, set EGO 2 Port to "Analog In 1" to use the second O2 connection in the 6 pin collector. You will also need to assign each injector output to a specific O2 sensor when using two O2 sensors. Once you have set everything needed on this page, click Burn and then close the AFR / EGO Control window.

At this point, you'll want to check the sensors reading on the main dash. Once you're done calibrating the sensors, check them from the main dash. To change any gauges, Right-Click on them and pick a different gauge. The ones we need here are under the Sensor Inputs categories. Check each of the following with the key on and engine off:

- Make sure the coolant temperature is a reasonable value.
- Manifold air temperature should be close to the CLT reading if the engine is cold.
- Confirm the throttle position reads 0 with closed throttle and close to 100% af full throttle.
- MAP sensor should read approximately 100 kPa if you are close to sea level. It may drop as low as 80 kPa at high altitude (over one mile). If the MAP sensor is reading below 80 kPa or above 105 kPa, check MAP sensor calibration.
- The air/fuel ratio will not give a useful reading with the engine off.
- Engine speed should be zero. If RPM ever reads anything like 65000 rpm, it means you have made an error in your configuration settings. Normally, this will appear as an error when you first connect. In the unlikely case that it does not, open up Communications, MiniTerminal and turn the MS3-Pro off then back on again. You'll get a message explaining what is wrong. Close MiniTerminal and fix the faulty settings. Then turn the MS3-Pro off then back on again.

Testing outputs
The MS3-Pro also allows you to confirm that your outputs are working through TunerStudio. The screen to do this is under CAN Bus / Test Modes -> Output Test Mode – Inj / Spk. The Enable Test Mode button is locked out unless the RPM reading is zero. Click this button to enable test mode, and when you are done, click the Disable Test Mode to go back to normal operation.
You don't want the fuel rails pressurized when you run the injector...
test mode. Remove the fuel pump relay before running this test (as the MS3-Pro will activate the fuel pump for 2 seconds on key on), and if necessary, depressurize the fuel rail. You will, however, need the fuel pump output set to on to test the injector and coil outputs, as this output also commands the relay that controls the coils and injectors.

To make the coils and injectors fire, we recommend setting the output interval to 100 ms, the testing mode to Sequence, and the coil or injector to test as H. This will make the MS3-Pro fire the coils or injectors in an A through H sequence according to the firing order. For the injectors, also set the total number of injections to 60000. Then click Start and to have the ECU fire the outputs. Both the coils and the injectors typically make enough noise that you can hear them fire. Caution – sometimes an engine, even one that has been sitting for months, may have enough fuel in one or more chambers to light off a cylinder or two in coil test mode.

Once you have confirmed that the injector and coil outputs work, re-install the fuel pump relay and use the fuel pump control buttons to check if the fuel pump is working as well.

**Calibration settings**

TunerStudio provides default calibrations for the MAP sensor, coolant, and air temperature sensors. The default tune should have the oil pressure sensor settings, but if you have loaded a tune without these, here are the settings you will need.

- Source: Analog In 2
- Field name: Oil pressure
- Transformation: Linear
- 0 V value: -16.3
- 5 V value: 146.3
- Lag value: 75

At this point, you're ready to get started. You will want to save the tune before you attempt to crank the engine (in case you need to refer back to it) and we recommend starting a data log before your first attempted start. For more details on how to tune the MS3-Pro and how to use its inputs and outputs, consult the full MS3-Pro manual available on the USB stick or at this link:

[http://www.ms3pro.com/downloads.html](http://www.ms3pro.com/downloads.html)
Wiring diagrams

MS3-Pro wiring: Power, ground, fuel
MS3-Pro Wiring: Ignition and idle
MS3-Pro wiring: Sensors
MS3-Pro wiring: Relay module
MS3-Pro wiring: Body and spare
MS3-Pro wiring: Communications
DIYAutoTune
3690 Burnette Park Dr., Suite D
Suwanee, GA 30024
USA
678-261-8789
support@diyautotune.com