
PLUG & PLAY

Quick Start Guide

GM LS 24X Drop On Harness

        MS3Pro ULTIMATE



For GM LS Engines with 24X Crank Triggers
Thank you for your purchase and support of American made products!  We have designed this drop on harness 
to support anything from a stock motor swapped into a vintage muscle car to serious drag racing applications. If 
you have any questions about your installation, please contact us at support@ampefi.com.  This Quick Start Guide 
includes installation, basic configuration and testing procedures concluding at engine start up for MS3Pro ULTI-
MATE-specific GM LS 24x Drop On Harness & ULTIMATE ECU.  For more detailed information, please visit the MS3Pro 
ULTIMATE User Manual on the included flash drive or our downloads page at https://www.ampefi.com/downloads/

Parts Included:

• MS3Pro Ultimate ECU
• USB thumb drive with software and instructions
• Complete wiring harness with fuse block and fuses included
• RS232 (DB9) serial tuning cable and DB9 to M12 adapter
• USB tuning cable
• 6 pin gray connector for O2 sensor connections
• 6 pin black connector for transmission control or other expansion devices
• 15 crimp pins for above connectors
• 100 ohm resistor for alternator light installation
• Ground wire for fuel pump

Every MS3Pro ECU purchase includes a FULL TunerStudio registration. To register TunerStudio, please visit https://
www.efianalytics.com/ms3pro/  Your serial number is located on a silver decal on the ECU enclosure bottom. The 
registration code is valid for one user with up to three tuning computers, and there is no limit to how many ECUs 
you may use with the registered version of TunerStudio.
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Applications
This harness is designed to fit all engines in the LS family using 24X crank trigger, including Corvette, F-body, and 
truck engines. We offer three variations based on the injector type. The harness was designed to accommodate 
both car and truck intake manifolds, as well as most aftermarket manifold options.  The harness also requires the 
use of a cable operated throttle body with OEM-style TPS and IAC connectors; non stock sensors or IAC valves may 
require minor changes.  A few unusual intake manifolds (particularly carburetor style or independent runner de-
signs) will require basic extension of some wires to fit relocated components.

A few engine variations may require minor changes.  For example, some truck engines used a one wire oil pressure 
sensor switch located behind the intake manifold. MS3Pro's oil pressure input requires swapping to a three wire oil 
pressure sensor.  Some alternator brackets (particularly aftermarket alternator relocation kits) require a lengthened 
alternator connection. Avoid splicing or cutting by using p/n: MS3Ph-LSAlt (sold separately). 

EV1 Injector EV6 Injector Multec Truck Injector
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Pre-installation Considerations & Descriptions
This harness is designed for installing MS3Pro and the fuse block in the passenger compartment, however, the 
ECU and fuse block are capable of withstanding underhood heat if they are mounted at least 12" (30 cm) from the 
exhaust system.  For unusually high vibration installations, use rubber vibration isolators to mount the ECU.  MS3Pro 
ULTIMATE’s IP65-rated enclosure is splash resistant but should not be continuously submerged. If you need con-
tinuous immersion resistance, you may reinforce the rubber seal with RTV silicone.  We designed the harness using 
high-temp resistant wire & loom; however, avoid routing it too close to the exhaust system.  

The harness splits into two main branches on the engine, which join above the bellhousing.  The even numbered 
cylinder section includes the crank sensor, right injector and coil banks, starter solenoid, and IAT (intake air tem-
perature) sensor connectors.  The odd numbered section includes connectors for the oil pressure sensor (connected 
to Analog In 2), knock sensor subharness, MAP sensor, cam position sensor, left injector and coil banks, alternator, 
coolant temperature sensor, throttle position sensor, and IAC valve. 
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The Body Control branch contains critical connections to the vehi-
cle electrical system:

• Purple: Starter solenoid power. Connect to starter relay. (14 AWG)

• Brown: Alternator light. The alternators on these motors use the 
                 same wire to supply a turn on signal and activate a warn-
                 ing light at low output. (20 AWG)
    
• White / Red: 12 volt switched power. (20 AWG)

• Purple / Red: Supplies 12 volts for the fuel pump. (10 AWG)

• Light green / Purple: Tach output signal. Supplies a tach signal to                                   
    stock or aftermarket tachometers or RPM signal to shift
                 lights, fuel pump controllers and other components   
    accepting a tach signal.  Output is a 0-12V square wave;
                 some OEM tachs require a high voltage adapter. (20 AWG)          

Before installing the harness, check to be sure you have access to the rear of the engine. On some swaps, you may 
have an easier time installing the harness if you first unbolt the hood to improve accessibility.
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Step-by-step Wiring Directions

1. Disconnect the battery.

2. Begin by cutting a hole in the firewall and feeding the harness through from the inside to the engine.  The mini-
mum recommended hole diameter for the wiring harness is 1.75" (45 mm).

3. Under the hood, position the odd numbered cylinder branch of the harness along or under the injector fuel rail.  
Connect the IAC, TPS, coolant temperature, odd numbered injectors, left coil subharness, and alternator connec-
tions.  If the alternator does not mount in the stock F-body or truck location high on the left side, splice and extend 
the alternator connection wire, or use p/n: MS3Ph-LSAlt plug-in extension.
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4. No alternator charging wire is included with the harness due to the large number of possible battery locations.  
Connect the alternator output terminal lug to the battery positive terminal. Use a minimum of 4 gauge for a 150 
amp alternator & 6 gauge for 100 amp alternator. For additional protection, we recommend installing a circuit 
breaker on this lead.
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5. Next, attach the connections at the rear of the engine. Connect the knock subharness connector, cam position 
sensor, oil pressure sensor, and MAP sensor.

6. The harnesss also includes a ring terminal to ground the coils that connects to the bolt hole on the back of the 
cylinder head using an M10 x 1.5 mm bolt. Make sure the bolt is torqued tightly and the ring terminal is not able to 
rotate while the bolt is tightened. Using an excessively long bolt often results in a bad connection and intermittent 
sparks.

7. The harness also 
incorporates a single 
heavy gauge green 
wire that supplies 
12 volt fused power, 
which can be used to 
run a cooling fan or 
other ECU controlled 
device through a relay 
inside the fuse box. 
MS3Pro drives this 
output through High 
Current Out 1.

8. Run the even num-
bered cylinder harness 
under or along the
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fuel rail. Connect the even numbered injector plugs and the right hand coil subharness plug.  

  9. Bolt the ring terminal at the front       
 of the even numbered cylinder har-
   ness to the front of the cylinder 
   head using a M10 x 1.5 mm bolt.
   Make sure the ring terminal is not
   able to rotate on the bolt.

10. Connect the IAT sensor. If your engine does not have a provision for the IAT,
mount it using a bung in the charge pipe, or tap into a suitable location on the 
intake manifold and thread in an IAT sensor. On many truck intake manifolds, 
the canister purge solenoid location is a good place to tap for the sensor. If you 
are using a metal intake manifold, we recommend mounting the IAT sensor in 
the charge pipe instead.
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11. Support the front end of the vehicle on jackstands and remove the starter. Run the foil wrapped wire down to 
the vicinity of the starter.

12. Connect the crankshaft position (CKP) and starter relay wires.

13. Re-install the starter.

14. The branch with 4 gauge wire and 
the 20 gauge white wire connects 
to the battery or master disconnect 
switch. The red wire and the white 
both connect to the positive terminal, 
while the black wire connects to the
negative terminal. Optionally, you can 
use a circuit breaker on the 4 gauge 
red wire. (125 to 150 amp circuit 
breaker recommended)
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15. Your MS3Pro ULTIMATE uses a 3rd (center) flying lead harness with 
black 23 pin connector that contains much of the ECU’s expanded 
input/ output capability. At minimum, pin 23 of the black connector 
(Keep Alive Memory- red wire/ white stripe) MUST connect to a 12 volt 
constant power source in order for ULTIMATE to power up.  

16. Connect the five wires on the Body Connection lead.
(reference p.4)

17. Connect the solid purple starter wire to the vehicle's starter relay 
wire. This will trigger the starter solenoid.

18. Connect the brown alternator wire to the alternator warning light 
wire. We recommend putting a 100 ohm, 2 watt or greater resistor (in-
cluded with the harness) in parallel with the alternator light to energize 
the alternator if the light fails. If the vehicle does not have an alternator 
warning light, connect to switched +12V through the supplied resistor.

19. Connect the white and red wire to a wire from the ignition key that 
receives 12 volt power 
with the key in both the Run and Start positions.

20. The purple and red wire supplies 12 volts to the fuel pump. Con-
nect this wire to the fuel pump positive terminal.
If you do not have a wire for the negative terminal, you can use the
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supplied fuel pump ground wire to connect the negative terminal to chassis ground.

21. Connect the light green & purple wire to the vehicle’s tachometer signal wire, if so equipped.

As this is a racing harness, it does not include all the connectors on an OEM wiring harness. You may have sever-
al devices on your engine that do not have a connector provided in the MS3Pro harness, including the following 
items:

• Mass air flow (MAF) sensor

• Clutch switch

• OBD2 diagnostic port

• Evaporative emission canister purge solenoid

• Oil level sensor

• EGR control solenoid

The MS3-Pro is a racing engine controller and does not require these features to run. The O2 sensor inputs are 
brought out to a separate 6 pin connector, as we anticipate that most users are more likely to run aftermarket wide-
band O2 sensor systems instead of factory O2 sensors.
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Connecting Optional Features
All unused wires to the MS3Pro are brought out on the Spare wire trunk and the (center) flying lead harness with 
black 23 pin connector.

Use these wires for A/C control, boost control, ad-
ditional sensors, traction control, or other inputs 
and outputs. Vehicle speed input is optional; the 
MS3Pro does not require vehicle speed for most 
of its calculations. See the MS3Pro User Manual 
for details on using these connections. 

All wires on the spare harness are 20 gauge. 
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Connector  Pin number  Function     Wire color    Stripe color

White   2   High current out 2    Light green    Dark blue
White   3   Injector out J     White     Yellow
White   4   Injector out I     White     Gray
White   5   High current out 3    Light green    Red
White   14   PWM out 1     Light green    -----
White   17   Analog in 7     Green    Orange
White   18   Sensor ground    Black     White
White   21   Analog in 3     Light blue    Purple
White   22   Analog in 4     Light blue    Pink
White   23   Analog in 5     Blue     Orange
White   29   PWM out 2     Light green    Pink
White   30   PWM out 3     Light green    Dark green
White   32   Digital switched in 1    Gray     Orange
Gray   17   Digital frequency in 2   Purple     Red
Gray   19   Digital switched 12V in   Gray     Dark blue
Gray   20   Digital switched in 2    Gray     Red
Gray   21   Digital frequency in 3    Purple     Dark blue
Gray   22   Digital frequency in 3 VR+   Purple Shielded  -----
Gray   23   Digital frequency in 3 VR-    Blue Shielded   -----
Gray   28   Digital frequency in 1   Purple     White
Gray   29   Digital switched in 3    Gray     Purple
Gray   34   Digital frequency in 1VR+   Purple Shielded  -----
Gray   35   Digital frequency in 1 VR-   White Shielded  -----
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Black   1   PWM out 5       Light green   Red
Black   2   PWM out 4       Light green   Orange
Black   3   Digital out 2       Brown    Dark blue
Black   4   Digital out 1       Brown    Dark green
Black   5   Digital I/O 4       Brown    Pink
Black   6   Digital I/O 2       Brown    Orange
Black   7   Analog in 8       Light blue   Purple
Black   8   5V+ VREF out 2      Gray    Black
Black   9   Fuel only coil negative     Black    Red
    (do not use with factory LS ignition) 
Black   10   Digital switched in 5      Gray    Orange
Black   11   Digital switched in 4      Gray    Pink
Black   12   Digital I/O 5       Brown    Red
Black   13   Digital I/O 3       Brown    Light green
Black   14   Digital I/O 1       Brown                              -----
Black   15   5V+ VREF out 2      Gray    Black
Black   16   Fuel only battery 12V+     Red    Black
    (do not use with factory LS ignition)
Black   17   Sensor ground     Black    White
Black   18   Sensor ground     Black    White
Black   19   Sensor ground     Black    White
Black   20   Sensor ground     Black    White
Black   21   Sensor ground     Black    White
Black   22   5V+ VREF out 1      Gray                                  -----
Black   23   Keep alive power [KAM] (REQUIRED)   Red    White
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Sample Device Wiring

 2 Step Input Switch:

  To MS3Pro switched input
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 Boost control solenoid:
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 Vehicle Speed Sensor (VSS):

 Use the following diagram to wire a threaded body Hall Effect Sensor as a driveshaft or wheel speed sensor.   
 This particular sensor requires a 2.4K resistor between its power and signal wires; PAY SPECIAL ATTENTION 
 TO THE WIRE COLOR SCHEME:  BROWN = POWER,  BLACK = SIGNAL, and BLUE = GROUND. 
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 NOTE: Any digital frequency input can be used as a speed input. It is also possible to use a switched input
 for speed input, although the maximum speed it can measure is significantly lower.

 If using an AMP EFI Trans Controller to control the transmission, vehicle speed is transmitted to MS3Pro over   
 the CAN connection.    Tip: To get a vehicle speed signal from a front wheel, you may often use a Hall Effect   
 Sensor and have it pick up the rear of the wheel lug studs.

O2 System & TCU

Connect your factory O2 or aftermarket wide band O2 sensors to the gray 6 pin Amphenol AT connector according 
to the pinout below: 

1. No connection

2. Second O2 sensor signal (MS3Pro Analog Input 1)

3. Primary O2 sensor signal (MS3Pro O2 Input)

4. Sensor Ground (If using a 4 wire O2 sensor, connect the sensor returns here. If using a wideband controller with a 
separate analog ground, connect it to this wire.)

5. Power Ground  (If your sensor or controller has a heater ground, connect it to this wire. If your wideband control-
ler has only one ground, connect it to this wire.

6. Switched 12 V+ Power (Use for powering a 4 wire sensor heater or for powering your wideband controller.
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The black TCU connector can be used for controlling the transmission, a CAN-EGT, aftermarket dash, or other CAN 
enabled devices according to the pinout below:

1. Clean power. Use for powering the Trans Controller, CAN-EGT Thermocouple Interface, or other digital device.

2. CAN bus high (CAN-H)

3. CAN bus low (CAN-L)

4. No connection

5. Ground

6. Solenoid power  (Use for powering transmission shift solenoids or other actuators.
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Relay Module
The harness is equipped with a sealed module that 
uses mini (ATM type) fuses and micro relays.  Note that 
inserting a fuse (any size) into the emtpy slot marked 
“Test” will cause the fuel pump, injectors, and coils 
to power up at any time the key is on, bypassing the 
MS3-Pro fuel pump output control. This is to help with 
troubleshooting.

The four holes at the corners of the relay module are 
threaded for #10-32 machine screws. Use caution while 
tightening these, as the maximum torque is 24 in-lbs.

MS3Pro allows testing the injectors and coils prior to  
starting the engine for the first time or after making   
substantial engine changes.  A good rule of thumb is to remove the fuel pump relay before running this test to pre-
vent the fuel pump from pressurizing the fuel rails. MS3Pro will switch the fuel pump on for two seconds after first 
receiving power, so do this prior to turning on the key.

Getting ready to start
Once you have the harness on the engine, connect to the ECU with TunerStudio and select a suitable base map for 
the engine.
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Installing the software
The USB stick should install TunerStudio 
when you plug it into your laptop. If the 
installer does not begin automatically, select 
the USB stick manually from Windows Ex-
plorer or Finder and run the Setup.exe file. 
We'll present a short walk-through of how to 
set it up here; for full details, consult section 
2 of the MS3Pro User Manual.

Once the TunerStudio software install is com-
plete, connect MS3Pro to your laptop using 
either the USB or RS232 serial cable. From 
Choose Create New Project and the adjacent 
screen will appear.

1. Enter a name for your project

2. Click DETECT; TunerStudio will detect the 
firmware on your MS3Pro.  If there is no defi-
nition file, TunerStudio will use your internet 
connection and prompt you to download 
one automatically for any standard release 
firmware versions.
3. Enter any notes about your project.
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Clicking NEXT will launch a project specific settings screen. The first option allows you to display the air/fuel ratio if 
using a wideband oxygen sensor, or voltage from a narrow band oxygen sensor. Option 2 sets the temperature dis-
play for Fahrenheit or Celsuis. You may leave the other options at their defaults. Click NEXT again to test communi-
cations. Click NEXT again to customize and select your gauge layout; click NEXT to finish creating the project. Once 
your project is created, TunerStudio will display the HOME screen.
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Entering your specific engine settings
If ordered as a package with the LS drop on harness, the MS3-Pro will ship with a startup tune based on a stock 4.8 
truck motor. You will need to make a number of adjustments to match what engine variant and sensors you are 
using. The USB flash drive includes alternate startup tunes. Some third party resellers may also provide tunes for 
specific packages as well. To select an alternate startup tune, go to File -> Open Tune (MSQ). If using a tune from the 
USB drive, browse to the USB drive and double click on the tune to open it.

Next, make sure the tune is set up for your 
engine size. Go to Basic / Load Settings and 
select Engine and Sequential Settings. Enter 
the engine size in cc and the injector size in 
cc/min in the lower right hand corner of the 
box that opens. (If you only have the injec-
tor size in lb/hr, multiply your lb/hr injector 
size by 10.5 for a cc/min. conversion).

Once you have entered these settings, click 
"Required Fuel..." button in the upper left 
hand corner. Make sure all the
settings in this box are correct for your ap-
plication, then click OK. Once this is com-
plete, click BURN and close the Engine and 
Sequential Settings dialogue box.

GM LS 24X v1.0                                                                                                                                                                                                      24



The other main setting that needs addressing to match your build is for oxygen sensor(s).

Go to the Tools menu and select “Calibrate AFR Table. “ (If this is grayed out, first unlock it under Tools -> Un / Lock 
Calibrations.) Select your sensor type from the drop-down menu, then click Write to Controller. 

We also recommend calibrating the TPS at this point. Go to Tools ->Calibrate TPS. With the throttle closed, choose 
"Get Current" on the closed throttle. Next, fully open the throttle and choose "Get Current" on the open throttle. 
Then click "Accept." If you are running other non-stock sensor types, such as a 3 bar MAP sensor, calibrate these from 
the Tools menu. Once all calibrations are complete, use Tools -> Un / Lock Calibrations to lock these settings so they 
cannot accidentally be changed.

A second place to set the oxygen sensors. Go 
to Fuel Settings -> AFR / EGO Control; enter 
your O2 sensor type and the number of O2 
sensors in use (top middle column). If you are 
using two O2 sensors, set EGO 2 Port to "Ana-
log In 1" to use the second O2 connection in 
the 6 pin collector. 

Next, assign each injector output to a specific 
O2 sensor when using two O2 sensors. Once 
you have set everything needed on this page, 
click Burn and close the AFR / EGO Control 
window.
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Once sensor calibration is complete, check them from the main dash for proper readings. To change any gauge, 
right-click it and simply choose a different gauge. The ones needed here are under the “Sensor Inputs” categories. 

Check each of the following with the key on and engine off:

  • Make sure the coolant temperature is a reasonable value.

  • Manifold air temperature should be close to the CLT reading if the engine is cold.

  • Confirm the throttle position reads 0 with closed throttle and close to 100% af full throttle.

  • MAP sensor should read approximately 100 kPa if you are close to sea level. It may drop as low as 80 kPa at high       
     altitude (over one mile). If the MAP sensor is reading < 80 kPa or > 105 kPa, check MAP sensor calibration.
  
  • The air/fuel ratio will not give a useful reading with the engine off.

  • Engine speed should be zero. If RPM ever reads anything like 65000 rpm, it means you have made an error in your          
     configuration settings. Normally, this will appear as an error when you first connect. In the unlikely case that it                   
     does not, open up Communications, MiniTerminal and turn MS3Pro off, then back on again. You should receive
     a message explaining what is wrong. Close MiniTerminal, fix the faulty settings and power cycle MS3Pro again.
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Testing Outputs
A confidence building feature within MS3Pro is Output Test Mode, which allow you to confirm that your outputs 
are working through the TunerStudio interface, prior to running your engine. To test your outputs, navigate to the 
CAN Bus menu and select Test Modes ->Output Test Mode – Inj / Spk. (The “Enable Test Mode” button will be locked 
out unless the RPM reading is zero).  To test, choose “Enable Test 
Mode” and to return to normal operation, choose “Disable Test 
Mode.”

Prior to testing, remove the fuel pump relay (as MS3Pro will ac-
tivate the fuel pump for 2 seconds on key on), and if necessary, 
depressurize the fuel rail. You will, however, need the fuel pump 
output set to on to test the injector and coil outputs, as this out-
put also commands the relay that controls the coils and injectors.

To fire the coils and injectors, we recommend setting the output 
interval to 100 ms, the testing mode to Sequence, and the coil or 
injector to test as H. This will force MS3Pro fire the coils/ injectors 
in an A through H sequence according to the firing order. For the 
injectors, set the total number of injections to 60000. Then click 
Start and have the ECU fire the outputs. Both the coils and the 
injectors typically make enough noise that you can hear them fire. Caution – sometimes an engine, even one that 
has been sitting for months, may have enough fuel in one or more chambers to light off a cylinder or two in coil test 
mode. Once you have confirmed that the injector and coil outputs work, re-install the fuel pump relay and use the 
fuel pump control buttons to insure the fuel pump is working properly.
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At this point, you're almost ready to start your engine. Just prior to cranking the engine, it is a good rule of thumb to 
save the tune file again with a different file name (in case you need to refer back to it) and start a data log. 

For more details on how to tune MS3Pro and how to use ALL inputs and outputs, visit the complete MS3Pro manual 
available on the USB drive or at the link below:

https://www.ampefi.com/downloads/

Hoffmann Innovations, Inc.
2405 Murphy Blvd.

Gainesville, GA 30504
USA

678-261-8789
support@ampefi.com
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